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Abstract 

This paper presents a computer based tool for those wanting to use the wave equation in their beam pumping design activities, but do not 
require the needs of a more sophisticated, full featured program. This program properly handles the problems faced by a person responsible 
for designing what could be termed normal rod pumped installations. The output of the program includes pump size, rod string, surface unit 
size, and motor size for an input depth and production rate. The author has found that accepted design practices are not used much of the 
time. Whether it is because they are too cumbersome and time consuming or that acceptable knowledge about proper design procedures are 
not widely understood, I do not know. The objective of this software is to help the designer implement state of the art beam pumping 
design technology without getting buried with details. The program is a WindowsTM program requiring Windows 3.x and a 386 class 
computer or better. All important input and output information is available on a single window displayed for the user. More detailed 
information including graphs may be optionally displayed. It uses a rapid solution method to the damped wave equation allowing the user to 
see immediately the effect of changing a parameter such as tubing anchor, stroke length, stroke rate, and pump diameter. Correlations are 
used for the motion of conventional, Mark llTM and air balanced units. allowing the program to determine the size of the pumping unit 
required. Tapered rod strings (API taper) and FiberGlasslSteel combination strings are allowed. A full featured context sensitive help file is 
available to the user. This means that whenever the main screen is active you can get help by simply pressing rt.The program is suitable for 
use on a desktop or laptop computer with or without an attached printer. Provisions are made for results to be saved to files for later 
examination. 

What is Mod? 

QRod ‘is a beam pumping simulator. After the user supplies the input data appropriate for the problem at hand, the program mathematically 
simulates the motion of the surface unit. It then solves the partial differential equation describing the motion of the rod string. Next it 
calculates the gear box torque, determines proper counter balance and displays the results. If the AutoCalc option is selected all of the 
results are immediately refreshed upon changing any input data. This allows the user to immediately see the effect of changing input data. 
All commonly changed input data and output information are presented on one window for quick inspection by the user. This output may be 
enhanced by displaying graphs and tables. 

There are three primary design variables for a beam pumping system once a depth and desired pumping rate are known. They are: 1. Stroke 
Length, 2. Pump Diameter, and 3. Stroke Rate. The user must change these 3 input variables to achieve the desired design objective. The 
desired design objective may be to minimize power required, or minimize rod loading for example. The user may also change secondary design 
variables to fit the particular situation. QRod has number of secondary design variables including Unit Type, Rod String Type, Pump Inlet 
Pressure, Fluid Specific Gravity, Tubing Pressure, and Damping Factor. Additionally, the user may change several mathematical parameters to 
obtain the desired speed and accuracy of solution. 

What Can QRod Do For Me? 

QRod was developed to be a useful design tool. If you need to select a pumping unit, rods, and a pump size for a well, it can be very 
helpful. While it is not designed to be an analysis tool you can use QRod to check an existing pumping system. Also, QRod was not designed 
to replace a full featured beam pumping simulator when the effects of motor slip, deviated hole, fluid inertia, and partial fillage are 
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important. It is designed to replace API RPl IL type caicuiauons with a mucn more accurate solution that is still easy to use. You will find 
ORod useful both in the office and on the laptop computer iv the field for design and trouble shooting wells having beam pumping system 
problems. 

When Should I Use QRod? 

You should always use some kind of design procedure on beam pumping installations to have a more efficient system and to minimize 
failures. You should use QRod to design and check normal beam pumping installations. QRod will not be as accurate as full featured 
simulators when your design involves motor slip, deviated hole, fluid inertia, and partial fillage. Fluid inertia is important for shallow ( < 2500 

, ft) wells having large ( > 2 112 inch) pumps. You will find that QRod gives more accurate results than the API RPl 1 L method. 

How Does ORod Work? 

QRod solves the damped wave equation describing the motion of sucker rods in a beam pumped well using a finite difference technique. The 
solution requires input to the boundary conditions of the problem. These are a description of the motion of the polished rod as a function of 
time and a description of pump loading as a function of pump position. The surface boundary condition is satisfied by using correlations for 
the various kinds of pumping units. The pump boundary is satisfied by logic in the program that determines if both valves of the pump are 
closed or if one of the valves is open. Careful experiments have shown that when QRod is run the results obtained are very close to what 
actually occurs. 

Designing a Beam Pumping System with Mod 

In order to help you learn how to use QRod is would be helpful for you to go through an example problem. Let us design a pumping system 
to pump 400 BP0 of .95 Specific gravity fluid from a depth of 5000 ft in this example. The following sequence of steps is helpful, but you 
do not have to do all things in the order shown. The text will give the mouse actions required, but you can use keystrokes if you like. 

Select Depth, Target Rate, Stroke length, and Pump Diameter 

Enter the depth (5000) and target rate (400). You may enter these values by typing the appropriate numbers in the active boxes and using 
the TAB or ENTER to get to the next box. You may also select the values from the pull down list. Notice that none of the other boxes on the 
screen are enabled [they are grayed) until you fill out depth and target rate. Any item that is visible, but grayed, may not be selected. After 
starting the program and entering these initial values, the main screen will appear as shown in Figure 1. 

Next enter a stroke length. A reasonable value for this situation is 144 inches, although others could be used. The pull down list contains 
only the standard API strokes when the pin of the unit is in the maximum stroke available. You may enter any value from 24 to 300 inches 
by typing as before. Next select the pump plunger diameter. You may want to examine the Help for pump diameter where information about 
the maximum sizes of pump that can be run it various sizes of tubing. Let us assume that we will use 2 l/2 inch tubing on this well, so the 
maximum size rod pump we could run without and on/off tool is 2 inch. Select a 2 inch diameter pump. When this selection is made, you 
will see the remainder of the window become enabled. Notice that anchored tubing is the default for that option. At this point the main 
screen appears as shown in Figure 2. 

Check the Settings Window 

Next, check the Settings window. This is where little used parameters may be changed: Bring up the Settings window by clicking on 
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Settings in the File Menu. When the window comes up you will see the first item is Report Header Text. Any text you put in this box will 
appear on the first line of any report. You will see 10 other boxes with numbers in them. The numbers are the default values for the various 
parameters. Also you will see OK, Cancel, and Reset buttons. 

The OK button will close the window, saving all the values as they appear in the boxes at the time the window is closed. The Cancel 
button will cause the window to be closed with no action taken. The Reset button causes all the values to be reset to the factory defaults. 
The 3 values inside the “Effective Upon Restart” box will not take effect until the nexttime you run the program unless you select Restart 
from the File Menu after the Settings window is closed. 

For the example problem the only parameter we need to change is Fluid Specific Gravity. Click on the appropriate box (or TAB it) and edit the 
value by typing .95 in the box. You may use delete or backspace as required in the edit operation. To erase the old value you can highlight 
it by dragging over the number and then pressing DELETE. At this point the Settings window will look like Figure 3. Click on OK to close the 
window. At the same time current settings will be save to a file named QROGCFG in the OR00 subdirectory. That file is read each time 
you restart the program. Notice that a reminder about the Restart appears. Click OK and get back to the main screen 

Select Rod String Option 

For this example let us try both steel rods and fiberglass/steel combination strings. First we will try steel rods. The steel rod option is 
already checked. 

Pick Rod Sizes 

86 rods have been selected by default. That is probably a good place to start for this problem. 86 rods are a 3 taper rod string composed 
of 1 inch, 718 inch and 314 inch rods. The percentage of each size is determined by the API method and depends of the pump diameter. This 
method will result in approximately equal stresses at the top of each rod section or what is referred to as a balanced design. 

Pick Rod Grade 

Select a rod grade start with, say grade “C. 

Select Unit Type 

The default unit type is CWConv which is a clockwise rotating conventional unit. We will use that to start with in this example. 

Select Stroke Rate 

The stroke rate is set when the program knows what unit type and stroke length you have selected. The value is set to about 65% of the 
value which will result in a downward velocity faster than the rods will fall in fluid. You may select the stroke rate by one of 2 methods. 
You may slide the Stroke Rate slide button with the mouse or you may click on the SPM for Tar Rate check box. 

Manual Setting of Stroke Rate 

For this problem, the program has set the stroke rate to 13.1 SPM. Click on ReCalc to calculate the problem with the data you have 
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entered. (If you check the AutoCalc check box the program will automatically recalculate for you every time you change an item.) Notice :, .,,, 
that this combination gives us a production of 700 BP0 as shown in Figure 4. The combination of stroke length, stroke rate and pum/, .$izl’““*’ 
is too large for the problem at hand. Next we will look at the automatic determination of stroke rate. 

Automatic Calculation of Stroke Rate 

If you click this button an “X” is put in the check box. We say that the box is “checked”. The program will then determine what stroke rate 
is required to get the target rate. Upon doing this you will find that the result is 8.4 SPM that gives a producing rate of 404 BPD. The 
calculation stops when the answer is within 1% of the target as shown in Figure 5. 

We need to improve on our design for this example, but first let us look at the 2 remaining buttons on the left side of the main screen. 

Choosing AutoCalc 

If this box is checked, the program automatically calculates any time it has a new value, except when you change values in the Settings 
window. There are times when you will want to operate in this automatic mode. There are also times when you will want to operate in the 
manual mode when the calculations are not made until you press the ReCalc button. It is really an individual preference almost as to 
whether you use AutoCalc or not as the program does not take too much time to make one cycle. 

Using the ReCalc Button 

When this button is pressed, the program recalculates the problem. Each time this is done 4 pumping cycles are simulated and the torque 
calculations are made. After that is done all output showing is refreshed. 

looking at the Output 

All of the important output from the program is on the right hand side of the screen. More detailed output is available in secondary windows 
where graphical information and more detailed text is available. 

Output Side of the Main Window 

The calculated rate, rod taper, rod loading, polished rod loads, peak torque, unit size and motor size are shown on this side of the screen. 
These are the most important results for a steel string design. For the example problem we see that for 8.4 SPM we get a rate of 404 
BPD. This is for an 86 rod string composed of 33.4% of 1 inch, 32.8% of 718 inch, and 33.8% of 314 inch rods. The loading on the top rod 
is 107.8% of the allowable for grade “C” rods meaning that the rods are over loaded. The loading is calculated using the modified Goodman 
diagram method. 

The PPRL [peak polish rod load) is 21,800 lb. and the MPRL is 5,800 lb. This means that the beam rating of the unit should be at least 
21,800 lb. The calculated peak torque for a balanced unit is 710,000 in-lb. This value determines the minimum gear box rating for the unit. 
The program displays the minimum unit size that satisfies all of the design requirements. Notice that there may not be a unit made with the 
calculated combination of gear box, beam rating and stroke. The values displayed are simply the minimum required. 

The last number displayed on the output side is motor size. This is the motor size determined from polish rod horsepower, the calculated 
cyclic load factor, and the mechanical efficiency of the surface unit. As with the unit, thjs number is a minimum value. The actual motor 

SOUTHWESTERN PETROL.EUM SHORT COURSE - 94 59 



used should be the next largest standard size. Before continuing with the design, let’s look at the graphs and other output. 

Craphs 

From the Window Menu, which became enabled when you calcu(a\ed the first time, select “Show Cards”. Notice that this item appears 
checked after you select this item. The next time you click it, it will be unchecked. As long as this item is checked, a small graph will 
appear on top of the main screen showing the surface and pump dynamometer cards each time the program recalculates. You can move the 
graph around by dragging it by the title bar. There is space for 2 graphs to be displayed over the ICON block on the main screen if you 
position them carefully. 

Next, select “Show Torque Curve” from the Window Menu. When you do this a new graph will appear, but the Cards graph will disappear. 
Both graphs are there, the Cards graph is just behind the main screen. To bring it to the front, click on ReCalc and you will be able to see 
both graphs and all of the output on the main screen if you position the graphs carefully. Figure 6 shows the main screen with both of 
these graphs displayed in the upper right hand portion of the main screen. 

Text 

If you want to look at more detailed information of all available output, select “Show Output Text” from the Window Menu. This causes the 
scrollable text window to appear containing this information as shown in Figure 7. If you position the main screen to the far left of your 
screen, place the 2 graphs over the ICON block and the output text window on the far right you will be able to see almost all of everything 
on all 4 screens at the same time. When the output screen came up it covered up part of the main screen. Press ReCalc which will bring 
the main screen to the top again. You will see that you can jump between each of the screens simply by clicking on them with the mouse. 

If you look at the text window You will see that the Counter Balance Effect required to balance the unit is 10,400 lb. Also you will see 
that the polished rod horsepower is 22 hp and the motor horsepower is 40. 

Tweaking the Example Steel Rod Design 

The design that we have at this point is not good enough. For one thing the rods are overloaded. You would think that one way to reduce 
the loading is to use a smaller pump. We have more capacity that we need anyway. We should be able to run at a higher stroke rate. So 
lets reduce the pump size to 1 l/2 inch. That is the largest rod pump that can be run in 2 318 inch tubing. After making that change and 
pressing ReCalc, we see that we now only have 247 BP0 at 8.4 SPM. The rod taper will changed slightly also. 

Click on the SPM for Tar Rate box to cause the program to determine the SPM for 400 BPO. Several interesting things appear. First of all, 
the rod loading is higher than before. Second, the Cards graph shows a slight bit of overtravel, that is the pump stroke is more than the 
surface stroke. On the output text screen you can see that the pump stroke is 149 inches. The most interesting thing is that the motor 
power has increased more than 50% to 63 hp. This is because of the increased friction in the downhole system. Remember that the friction 
there is proportional to rod velocity that was increased when we increased the stroke rate. 

Next try clicking on CCWConv from the Unit Type Menu. This runs the same problem, just rotating the unit in the counter clockwise 
direction. After pressing ReCalc (if you do not have the AutoCalc option set) you will see that we get the same production. However, the 
rod loading is down. Notice that the rod loading decreases, and motor power goes down to 54 hp, a decrease of almost 15%. Also the 
torque is down to the point that a smaller unit can be used. A click on Mark II from the unit menu will show that even a smaller unit can 
be used if it is a Mark II. 

Going back to the CCWConv unit selecting grade “0” rods we have an acceptable design. There is no correct design because the design 
objectives will differ from case to case. Any acceptable design should not exceed the allowable loading for any component in the system. 
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This result is shown in Figure 8. The design shows that a 912 unit is required although only 640,000 in-lbs torque is displayed. The actual 
value of torque is slightly over 640,000 but rounds to 640,000. This is yet another example that someone has to think when using a 
program that is almost automatic. 

Running the Same Problem with FiberGlass Rods 

Click on the FIGI option button in the Rods frame. This will select the FiberGlasslSteel combination rod string design. We now need to fill in 
the 3 blank boxes that have appeared. Select 1.2 inch for the FiberGlass size, 75% FiberGlass and 1.25 for the Steel rod size to start with. 
Click on SPM for Tar Rate to automatically determine the stroke rate. Voila! Interesting results, Hmmmmmmm. We get the same production 
with a lower stroke rate than with the steel rods because we get more overtravel with the FiberGlass. 

Intersection Information 

Lets replace the Torque curve with more important information pertaining to FiberGlass rods, namely the intersection loading. From the 
Window first uncheck “Show Torque Curve” then check “Show Intersection Info”. Press ReCalc and position the Information screen where 
the Torque curve screen was. We can see that the loading on the FiberGlass rods and the glass/steel intersection is 61%. However, we only 
have 700 lb. load on the FiberGlass for a minimum load. Since FiberGlass needs to be loaded in tension at all times, this may not be a very 
safe design. Also you will notice that the loading on the FiberGlass at the surface is low. 

Tweaking the FiberGlass Design 

Lets put a little more steel at the bottom, thereby reducing the chances of getting compression loading in the FiberGlass and at the same 
time save some money. Steel is cheaper than FiberGlass. Notice that we have pretty good overtravel, the pump stroke is 161 inches. We 
can increase the overtravel by increase the stroke rate, but that will decrease the minimum loads that will occur. 

Highlight the 75 in the Percent box and type in 70 and press ENTER. After pressing ReCalc you will see that we have a fairly good design. 
Notice that the production has gone up as a result of the additional overtravel so click on the SPM for Tar Rate box to get our design rate 
back.These results, along with the cards and intersection information are shown in Figure 9. 

If you click on the Steel option button in the Rods from and then on SPM for Tar Rate you will get the steel rod design back. So it is 
possible to easily go back and forth between FiberGlass and Steel to compare the 2 designs. 

The possibilities are almost endless. This looks like a good design, but the original case we did only required 40 hp so there is plenty to 
think about when designing an optimal beam pumping system. I will leave it to you to optimize this problem. 

Saving Text 

From time to time, especially when you are in the field on a laptop and do not have an attached printer you may want to save the results 
of a case that you have run. Just click on “Save Text” from the File Menu and all of the text that appears in the output text screen will be 
appended to a file named QROO.TXT in the QROO subdirectory. Each time you click on “Save Text” the current values will be appended to 
the file. At a later time You may examine and/or print the file or portions of it. You will need to erase the file periodically to keep it from 
becoming too large. QRod will create the file if it does not exist. 
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Printing 

You may select the printing of either graphs or text if you have a printer attached. Any printer supported by Windows should work fine, 
although better and faster graphics will result with a laser or ink jet printer. 

Graphs 

To print the graphs associated with the project, select “Print Graphs” from the File Menu. When You do this a text screen will pop up. This 
screen allows you to put any annotation you desire at the top of the printed report. You can put up to 4 lines of about 40 characters as 
you see fit. The information you type in will be available throughout the current session with QRod, although you may edit it as you see fit. 
Press CTRL+Z to cause the report to be printed. 

Text 

To print the text associated with the project, select “Print Text” from the File Menu. You will get the same request to enter report header 
information es with the graphs. Again press CTRL+Z to cause the report to be printed. 

Exit QRod 

To exit ClRod, select “Exit” from the File Menu. This will close the program down along with all associated windows and files. Additionally 
the positions of the windows you have moved will be save for the next time you run the program. 

Summary 

QRod is a program that obtains a solution to the damped wave equation describing the motion of sucker rod pump strings. It uses an 
approximation for the motion of the surface unit as the surface boundary condition. The results obtained include loads, stresses, torques, 
power, and pump displacement. I have attempted to put in all the features needed to do the job accurately without adding bells and whistles 
which tend to add very little to the accuracy but much to the complexity for many problems. GRod is best used in conjunction with a full 
featured sucker rod simulator such as RodMaster TM by S. A. Holditch and Associates when more detailed studies are required. ClRod was 

developed in Visual Basic 3.0 TM under MSOOS 6.2TM and Windows 3.11 TM. I hope you will try using the program end as I am sure that it 
will help you do your job more efficiently. 
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pump Depth = 5,000 ft 
Pump Diameter = 2.00 in 

Pumping Speed = 8.4 SPM 
Surface Stroke Length = 144 in 
Pump Stroke Length = 129 in 

Total Liquid 180% Pump eff) = 404 BPD 

Rod Number =86 
Rod Grade = c 

Rod String Taper = 33.4,32.8.33.8% 
TopRodLoading = 108% 

Tubing Pressure = 45 psi 
Pump Inlet Pressure = 75 psi 

Fluid Spec. Grav. = 0.95 
Fluid Load = 6,300lbs 

Anchored 2-1 /I?!” tubing 

Peak Pal Rod Load = 21800lbs 
Min Pal Rod Load = 5,800 Ibs 

Peak Gear Box Torque = 710,080 in-lb 
Unit Type = CWConv 

Min API Unit Rating = 912-256-l 44 
Counter Balance Moment = 1.279.000 in-lbs 

Counter Balance Effect = 10,400 lba 

Polished Rod Power = 22hF 
Min Motor [95% Unit eff) = 40 rY: 

Dimensionless Damping Factor = O.lC 

Figure 7 
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